Visual Studio 2013 hangs after each debug session

Stumbled upon this issue when Visual Studio 2013 Update 4 would hang after each debug session. Very annoying especially when you want to quickly run the application test something, fix code and back to the beginning of this cycle. The hanging would occur for about 15-30s every time I would close the application and debug session ends. To resolve this I tried a lot of solutions suggested by Google which didn’t help:

  • Resetting Visual Studio 2013 settings via “devenv.exe /ResetSettings”
  • Deleted *.suo file
  • Rebuilt new solution file with all projects
  • Even disabled internet as I was suspecting some sort of network communication issue was causing this
  • Attempted to disable git integration with Visual Studio by renaming .git folder to _git as a temporary solution
  • Tried to disable IntelliSense with no luck

The only solution that worked for me was to disable Visual Studio host process for the project. To do this on the Project menu, click Properties, then click the Debug tab and uncheck the Enable the Visual Studio hosting process check box.

Hope this post saves a few hours messing around with settings for somebody trying to resolve this issue.

If you enjoyed this post, please consider leaving a comment or subscribing to the RSS feed.

5 thoughts on “Visual Studio 2013 hangs after each debug session”

  1. Everything was okay on my desktop with VS2015.
    This problem occured with the same project on my laptop.
    I could avoiding hanging VS with your solution.
    Thanky you!

Leave a Reply

Your email address will not be published. Required fields are marked *